Emisar D4s, AUX LED Helligkeits-MOD

Dieses Thema im Forum "Modding" wurde erstellt von square74, 24. Januar 2019.

Schlagworte:
  1. Hallo,
    da mir vor allem bei der Amber AUX-LED-Farbe die Helligkeit zu gering war, wollte ich erst andere Boards oder Vorwiderstände (SMD-Trimmerpotis) verbauen.

    Nach einem Hinweis eines hier und im BLF bekannten Modders habe ich es gewagt und den Vorwiderstand einfach entfernt.

    Bitte nur nachmachen, wenn Ihr den Defekt der Lampe riskieren wollt.

    Das Ergebnis, seht selbst:

    Vorher mit Rv (1200Ohm):
    [​IMG]

    nachher mit entferntem Rv und gebrückten Pads:
    [​IMG]

    hier nochmals mit Optik davor:

    vorher mit Rv:
    [​IMG]

    nachher ohne Rv mit Brücke:
    [​IMG]

    Hier noch zwei Vergleiche meiner jetzt hellen Amber-Version mit meiner Standard Roten Version.
    Beide in der Einstellung AUX LEDs high:
    [​IMG]
    [​IMG]

    Es ist wohl so, dass die AUX LEDs über einen Ausgang der MCU angesteuert werden. Die MCU begrenzt wohl den Strom auf 20mA. Wie gut das der MCU tut, keine Ahnung.

    Die AUX-LED low Stufe bleibt ganz niedrig, da dort wohl ein interner Widerstand der MCU zugeschalten wird, der nicht mehr Strom zulässt.

    Ich bin jedenfalls mit dem Ergebnis sehr zufrieden ;).
     
    Ratzepeter, Franky K., Unix5566 und 3 andere Flashys haben sich hierfür bedankt.
  2. Armytek
    Eben habe ich mal eine Tailcap-Strommessung gemacht.
    Mit voller iJoy 26650er, 4200mAh Zelle habe ich einen Tailcap-Strom von ca. 38mA.
    Wenn der Output tatsächlich geregelt ist über die MCU mit ca. 20mA für die LEDs, dann sollte der Output lange Zeit bis leer stabil sein und die Elektronik benötigt ca. 18mA. Evtl. ist aber auch mein Multimeter zu ungenau...

    Ich weiß jetzt aus dem Stehgreif her gar nicht, wie sich die Lampe verhält, wenn man sie so weiter betreibt. Wird die Zelle dann komplett leer gesaugt? Tiefentladen?

    Mal angenommen ich quetsche alles aus der iJoy Zelle raus, dann habe ich bei dem geringen Strom sicherlich die 4200mAh bis die Zelle auf 2,8V runter ist.
    Rechnerisch dann 4500mAh / 38mA = 110Stunden.

    Würde mich schon reizen, das mal zu testen...
    Der Test startet dann morgen früh mit randvollem iJoy und ich messe immer wieder mal sicherheitshalber dazwischen die Zellenspannung nach...
     
    Unix5566 hat sich hierfür bedankt.
  3. Klasse Idee, wenn ich mir die D4S in SST-20 3000k noch bestellen sollte dann wäre einen helles Amber verlockend
    Bin auf deine weiteren Tests gespannt
    Danke fürs ausprobieren :thumbup:
     
  4. Acebeam
    Soviel ich weiß wird der Akku über die AUX-LEDs komplett leergesaugt, d.h. tiefentladen. Einen Schutz gibt es nicht.
    Ich hatte das mal in irgendeinem Thread gelesen.
     
  5. Könnte man ja auch mit einem Labornetzteil testen
     
  6. Das würde ich bezweifeln, wenn die Aux LEDs über die MCU laufen, dann könnte hier schon ein Schutz eingebaut sein.
     
  7. Das wundert mich auch. Muss mal suchen wo das stand.
     
  8. Stimmt das wirklich? Wer sagt das?
    Nach meinem Kenntnisstand begrenzen die Atmel-MCUs den Strom, der über einen I/O-Pin ausgegeben wird, ohne externe Bauteile nicht.

    Wird ein höherer Strom als spezifiziert entnommen, dann fließt der auch, aber eben mit entsprechender Überlastung der MCU.
    Stellt sich eben die Frage, wie lange die MCU das durchhält...
    OK, dann geht's ja noch.

    Soweit ich weiß hat doch der Treiber eine Attiny85 MCU und laut deren Datenblatt wird als "absolute maximum rating" der "DC Current per I/O Pin" mit 40 mA angegeben, das dürfte also gerade noch OK sein.

    Dennoch ist es keine besonders elegante Lösung einfach den vollen Strom ohne jede Begrenzung durch die MCU laufen zu lassen.
    Wäre es nicht vielleicht vernünftiger statt des alten Widerstands wenigstens einen neuen Widerstand mit entsprechend niedrigem Wert einzulöten? Vielleicht 100 Ohm oder so etwas, müsste man mal durchrechnen...
     
  9. Oder wie bei der E07 ein Trimmpoti
     
  10. Hab grade mal getestet.

    Original sind das ja 1,7 mA was da über den Widerstand geht.

    Hatte hier noch ne Stange 47 Ohm Widerstände in passender Bauform.

    Mit 47 Ohm sind es 22 mA das ist perfekt.

    Strom übrigens indirekt gemessen über Spannung am Vorwiderstand.
    Somit also sehr genau.

    Brat jetzt mal noch meine Rote um dann sind alle Farben gleich hell optisch.

    Gruß
    Manfred
     
    Unix5566 und steidlmick haben sich hierfür bedankt.
  11. Ergebnis:

    Amber und Rot mir 47 Ohm Mod.
    Grün und Blau Serie
    Die Kamera kriegt das nicht so schön eingefangen.

    Rot ist eigendlich schön Rot.
    Farben alle gleich hell.
    Rot nen Ticken heller
    20190124_211607-1.jpg
     
    square74, heiligerbimbam, oOFOXOo und ein weiterer Flashy haben sich hierfür bedankt.
  12. Ich erinnere mich auch, dass ToyKeeper im D4s Thread geschrieben hatte, dass die Aux LEDs immer weiter Strom ziehen.

    Und nach kurzer Suche habe ich es auch gefunden :)
     
    heiligerbimbam, steidlmick und Unix5566 haben sich hierfür bedankt.
  13. Hallo
    Ich danke Euch allen.
    Sicherlich ist ein Vorwiderstand besser als direkt bestromen.
    Hatte mir auch schon 1kOhm SMD Trimmer bestellt im 3x3mm Maß. Leider etwas groß vom Wert her.

    Wenn die da sind, dann kann ich mal versuchen einen ein zu löten oder ich frage einen Kollegen aus der Elektronik Abteilung.
    Morgen messe ich auch mal den Strom bei low und AUX LEDs aus. Die MCU braucht ja sicherlich nur minimal Strom im Standby.
     
  14. Der Kollege @urquattroblack hat doch mit einem 47-Ohm-Widerstand ein schönes Ergebnis erreicht.
    Nimm doch einfach so einen Widerstand, 47 Ohm ist ja ein gängiger Wert.

    Falls du solche Widerstände nicht rumliegen hast, man kann sehr gut alte Elektronik (Mainboards, Grafikkarten und anderer Kram dieser Art) für solche Versuche ausschlachten.

    Einen Trimmer mit 1 kOhm halte ich für keine gute Idee, weil die Belastbarkeit der Schleiferbahn von der Stellung abhängt und du müsstest einen Trimmer mit so hohem Wert weit herunter drehen, um auf 100 oder 50 Ohm oder so zu kommen.
    Bei so geringem Wert ist dann der Stromfluss über die kurze Schleiferbahn mglw. schon zu hoch und der Trimmer könnte durchbrennen.
     
    square74 hat sich hierfür bedankt.
  15. Olight Shop
    Ich hab hier noch ca. 40 Stück passende 47 Ohm Widerstände.
    War mal ne Fehlbestellung.
    Auch 50 Stück 33 Ohm sind noch da wenns einer noch nen Tick heller will.

    Wer welche braucht sagt Bescheid.
    Schick ich euch gegens Porto.

    Gruß
    Manfred
     
    square74 und Unix5566 haben sich hierfür bedankt.
  16. Normal macht das nichts, wenn Maximalstrom und Verlustleistung nicht überschritten werden.
    Achtung: wenn man das an mehreren Pins macht, kann es schnell zu Überlastung kommen. Oft gibt es zusätzlich zu den Einzelpin-Limits noch welche für Port-Gruppen oder den gesamten µC.

    Irgendwann schaltet der µC ab, und wenn die Vf der LED unterschritten wird, fließt auch kein Strom mehr.

    Irgendein Limit gibt es immer. µC-Pin-Treiber verhalten sich bis zu einem bestimmten Strom ziemlich ohmsch (ein paar 10 Ohm), darüber hinaus aber fast als Konstantstromquelle, deren Strom ziemlich stark von der Versorgungsspannung abhängt. Sind halt FETs.

    Wenn die Pins dafür spezifiziert sind, ist es sogar sehr elegant, weil es Bauteile spart :)
    Ob das bei den AVRs der Fall ist, kann ich aber nicht sagen. Bin zu faul, ins Datenblatt zu gucken...
     
    square74 hat sich hierfür bedankt.
  17. So,
    habe einen Randvollen iJoy in der Lampe und diese "leuchtet" (AUX LEDs high) seit 7:30Uhr hier unter dem Tisch.
    Habe nochmals heute morgen mit der Zelle die Ströme gemessen.
    AUX LEDs aus: 25µA
    AUX LEDs low: 90µA
    AUX LEDs high: 36mA

    Die Zelle hatte im Leerlauf 4,19V.
    Der Test läuft.
    Ich messe gegen Mittag nochmals die Zellenspannung und stelle eine Tabelle zusammen.


    EDIT:
    Ich habe noch ´ne zweite D4s hier mit AUX LEDs Amber, die noch original ist, habe eben mal auch nachgemessen:

    AUX LEDs aus: 26µA
    AUX LEDs low: 88µA
    AUX LEDs high: 1,76mA

    Die Zelle hatte im Leerlauf 4,17V.

    Ist schon ein großer Unterschied 36mA zu 1,8mA...
     
    #17 square74, 25. Januar 2019
    Zuletzt bearbeitet: 25. Januar 2019
    Liquidity, urquattroblack, oOFOXOo und ein weiterer Flashy haben sich hierfür bedankt.
  18. Was bei roten LED mit einer typischen Vf von 1,6V...1,8V in den Akku-Tod führen würde. Wenn auch sehr langsam.
     
  19. Das kommt nicht ganz hin.

    Mit dem Mod fallen am Widerstand 1,13 Volt ab.
    Gespeist wird das Board mit 2,9 Volt.

    Hab Grad mal das Labornetzteil ausgepackt.
    Der Strom geht mit der AkkuSpannung runter.
    Die Roten Leds gehen bei einer AkkuSpannung von 2,05 Volt aus.
    Kurz vorm Ausgehen ziehen sie noch 1,3 mA.
    Sobald sie bei 2,05 Volt ausgehen geht der Strom auf 0,3 mA runter.
    Mit fallender Spannung geht auch der Strom runter bis bei 1,13 Volt 0 mA erreicht sind.

    Das heißt für mich wenn die Aux ausgehen dann ist es höchste Eisenbahn und schon nicht mehr gesund.
    Man sollte den Akku aber noch retten können.
    Auf der anderen Seite ist der Strom kurz vorm ausgehen schon so klein das es lange dauert bis er so tief kommt.

    Wenn die Leds aus gehen geht's nochmal langsamer.

    Ich denke wenn man ein Auge dafür hat wann die Aux schon deutlich dunkler sind dann sollte man keine Probleme haben.

    Gruß
    Manfred
     
  20. Achtung das stimmt absolut gar nicht!
    Die MCU wird mit einem Bistabilen Ausgang einfach abgeschalten.
    D.h. dass der Ausgang bis auf 1,8V (auch die 85 kann die 1,8V selbs bei 10MHz noch stabil laufen) stabil auf high bleibt,
    darunter sehr wahrscheinlich auch noch wie tief müsste man einfach mal testen, aber vermutlich bis die LED Leuchstspannungsgrenze irgendwann bei 1,5V ist

    Das heißt die Zelle wird in jedem Fall tiefentladen
    Bei knapp 40mA ist selbst eine volle Zelle nach 4 Tagen Tiefentladen

    mann sollte hier lieber die Aux LEDs über einen Moonlight special Treiberfirmwaremod steuern, der die Aux LED mit lafender MCU ansteuert und somit die Batteriespannung überwacht, das müsste aber jemand proggen, wen man dazu die MCU weit untertaktet sollte man auf deutlich unter 1mA bei der MCU kommen
     
    #20 Lexel, 26. Januar 2019
    Zuletzt bearbeitet: 26. Januar 2019
  21. Einen Post drüber steht doch meine Messung.
    Damit sollte klar sein wie sichs verhält mit 47 Ohm.
    Da ist das dann nicht mehr ganz so tragisch.
     
    Unix5566 hat sich hierfür bedankt.
  22. Mal ne doofe Frage von einem Laien wie mir.
    Könnte man nicht eine Zenerdiode dazu schalten. Die dann oberhalb von vielleicht 2,7V durchschält und wenn die Spannung sinkt dann sperrt?
     
  23. Da brauchst nicht unbedingt eine Zenerdiode normale Dioden die ca. 1,2V durchlassspannung zusammen haben gingen auch
    die LED zieht strom bis ca. 1,5V runter, also brauchst du Dioden

    Natürlich geht auch mein Board mit LVP Abschaltung für D4S für D4 muss ich mal den Prototypen zusammenbauen
     
  24. Ich habe meinen Test oben nicht so ausführlich gemacht wie ich erst wollte, da erst gegen Ende das Ganze interessant geworden wäre.

    Ich hatte deswegen eine Emisar auf mittlerer Stufe (nicht heiß werdend) den Akku in die LVP treiben lassen. Die Emisar hat schön runtergeregelt, bis nur noch ein niedriges Low (evtl. Moon) zu sehen war, dann hat sie abgeschalten und die AUX-LEDs gingen an. Scheinbar gleich hell wie bei vollem Akku, zumindest Visuell. Messen konnte ich das Leuchten nicht.

    Die Zelle hatte da lt. Messung noch 2,8V.
    Ich habe die AUX-LEDs dann noch einige Zeit an gelassen und dann ging die Zelle auf 2,65V runter, ohne optisch sichtbaren Helligkeitsverlust der AUX-LEDs. Ich habe dann ab gebrochen, weil ich die Zelle nicht gefährden wollte und eh kein sichtbarer Helligkeitsverlust zu erkennen war.

    Mal ein paar neue Überlegungen / Fragen:

    Die AUX-LEDs auf dem Original-Board sind alle parallel verschalten?

    Tailcap-Strom 36mA.
    Die AUX-LEDs sind stark unterbestromt. 36mA/16=2,25mA.

    Die AUX-LED-Spannung kommt über den Attiny, aber eben nicht LVP überwacht und auch von der Akkuspannung abhängig / sinkend mit sinkender Akkuspannung. Sonst würde eine Diode ja auch nichts bringen, wie zuvor besprochen...

    Rv = Uv / I
    z.B. bei 4,2V Gesamtspannung und 1,65V LED-Spannung (für 2mA LED-Strom angenommen aus Diagramm) ergibt sich für den Rv = 4,2V - 1,65V = 2,55V, die verbraten werden müssen.
    Somit Rv = 2,55V / 0,002A = 1275Ohm, was in etwa dem verbauten Widerstand entspricht, soweit ok.

    Bei Niedriger Akkuspannung, z.B. 3,0V habe ich dann 3,0V - 1,65V = 1,35V für Uv.
    Somit fließt noch ein Strom von 1,35 / 1275 = 0,0011A.
    Somit nur noch der halbe Strom von vorhin. Ganz stimmen tut das nicht, da lt. LED-Kennlinie bei halbem Strom nur noch Vf 1,6V.

    Das alles findet aber in so einem geringen Bereich statt, dass das vielleicht für´s Auge nicht sichtbar ist.

    Wenn ich jetzt die Hälfte der AUX-LEDs raus löte (sind ja alle parallel) dann bekommen die restlichen LEDs den doppelten Strom und leuchten dann noch heller...

    Wenn die AUX-LEDs mit 1,5V nicht mehr leuchten und auch nicht mehr glimmen, dann wie folgt.
    Wenn ich jetzt also ´ne Abschaltung bei 3V möchte, dann muss ich 3V - 1,5V = 1,5V mit den Dioden verbraten, was zwei Dioden in Reihe heißt.
    Die Diode schält aber auch schon weit unter 0,7V durch, es wird also ein geringer Strom schon vorher fließen. Oder gibt es bessere Dioden mit Steiler Kennlinie, die z.B. unterhalb von 0,6V nichts durchlassen und ab 0,7V dann durchschalten?

    Ich könnte ja auch eine meiner Leuchtdioden, die ich bestellt habe mal in Reihe schalten.
    Die haben eine Vf von 2,1-2,3V und schalten sicherlich auch schon mit etwas weniger Spannung durch.
    Optisch auch ok, da selbe Leuchtfarbe.

    Ich teste das mal bei Gelegenheit...
     
    Unix5566 hat sich hierfür bedankt.
  25. Noch bisschen was Offtopic.
    Habe versucht meine Emisare D4S mal ab zu lichten:
    [​IMG]

    die Grüntöne der SST20-Versionen sind auf dem Bild etwas grüner als in Echt, bei der XP-G2 S4-5D kommt der Violettanteil auf dem Bild nicht genug rüber, die ist in Echt Violetter...

    Hier nochmals aus, mit besser lesbarer Beschriftung auf den Kartons:
    [​IMG]
     
    #25 square74, 28. Januar 2019
    Zuletzt bearbeitet: 28. Januar 2019
    Liquidity, djmykemyers, Stanley-B. und 2 andere Flashys haben sich hierfür bedankt.
  26. Kannst du beschriften? Oder Original hochladen irgendwo man kann es nicht wirklich lesen was auf den Kartons steht

    Danke
     
    square74 hat sich hierfür bedankt.
  27. Bekam es leider nicht besser von der Leuchtfarbe dargestellt.
    Hier meine drei Favoriten, dich wahrscheinlich behalten werde:

    SST20-3000K
    SST20-4000K
    XP-G2-S4-3D, 5000K,
    evtl. noch die XPL-Hi, V2-5D, 4000K oder die XP-G2, S4-5D, 4000K

    Die SST20-5000K ist grüner vom Licht bild her, als die wärmeren SST20-Versionen.
     
  28. SST20-3000K habe ich bei der D4 ein wahrer Traum
    bin gespannt wie die XP-L HD sich macht
     
  29. Hast Du schon eine?
    Ich möchte evtl. noch eine bestellen...
     
  30. Im Zulauf dauert aber noch eine weile
     
  31. Habe 2x 100Ohm übereinander gelötet komme auf ca. 20mA

    20190801_140724 (Large).jpg 20190801_140711 (Large).jpg 20190801_140624 (Large).jpg 20190801_140614 (Large).jpg 20190801_140555 (Large).jpg
     
Die Seite wird geladen...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden