Imalent Taschenlampen

Emisar D4 AUX Mod

goromyr

Flashaholic*
21 Januar 2015
351
291
63
Braunschweig
Trustfire Taschenlampen Gatzetec Shop
Hallo zusammen!

Ich möchte kurz einen Einblick in den Einbau der AUX Led Platine geben, welche von unserem Nutzer Lexel entwickelt wurden. Alle Fotos sind nur fix mit dem Handy geknipst wurden, um einen Einblick zu geben und andere zu animieren, sich auch an den Umbau zu wagen.

Zunächst wird der Lampenkopf geöffnet und die Optik und Glas entfernt. Dannach das Led Board entfernen.
19lkrv.jpg

Nun kommt der kritische Teil. Der Treiber muss vorsichtig heraus getrieben werden. Dafür habe ich ein Stück Schaschlik Spieß aus Holz verwendet. Die Kabel in der Durchführung etwas beiseite drücken und man kann den Treiber und ein paar Bauteile sehen. Am besten findet man eine Stelle wo keine Bauteile sind und platziert dort den Holzspieß. Meine D4 war nicht verklebt. Ein beherzter Schlag mit dem Hammer und der Treiber sprang heraus. Falls das nicht klappt den Kopf vorher heiß machen. Dabei aufpassen, dass die weißen Kabel vom Schalter nicht abreißen. Man kann sie natürlich wieder anlöten, aber es ist doch recht fummelig.
22zjrv.jpg

Um das AUX Board per Schalter bedienen zu können muss eine andere Firmware her. Die Firmware der D4s ist auf der Seite von Toykeeper zu finden.

Die Kabel für die AUX LEDs habe ich an diesen Stellen angeschlossen. Plus kommt an das freie Pad am MCU (rot). Minus kommt auf Masse (schwarz). Zb am großen Pad des AMC.
3uekcj.jpg


Nun die Kabel wieder durchführen und die Wärmeleitpaste unter dem Led Board nicht vergessen ;)
481kxx.jpg

Hier ist das AUX Board angeschlossen und muss nur noch ausgerichtet werden. Optik, Glas und Dichtungen wieder an die Stelle wie zuvor und zugeschraubt.
52vk95.jpg

So sieht das ganze jetzt aus: Mir gefällt es richtig gut !
65njt5.jpg


Zum Schluss noch ein paar Messungen:
D4 TiStandbystrom: 22,4 μA
D4 mit grünen AUX 424 μA
Zum Vergleich:
D4s mit Cyan im Low Modus: 72 μA
D4s mit Cyan im High Modus 1182 μA

Das D4 Board kann leider nur im High Modus betrieben werden. Aber das ist für mich zu verschmerzen. In meinen Augen hat der Umbau die Lampe total aufgewertet. An dieser Stelle nochmals vielen Dank an Lexel, dafür dass er das Board entwickelt hat und uns, wie ich finde, preiswert zur Verfügung stellt!

Gruß
Niklas
 

urquattroblack

Flashaholic**
22 Januar 2017
1.640
1.407
113
Seh ich das richtig das wenn man es nicht per Schalter bedienen möchte dann einfach anlöten und leuchtet immer?
 

Trabireiter

Flashaholic**
5 April 2012
1.431
682
113
in Sachsen
korrekt.

gibt hier jemanden der anduril für die d4 compilieren kann?

es müssen im der hw-def und cfg die Zeilen für die aux leds hinzugefügt werden.

die Nutzung der D4s Firmware hat dann doch ein paar Nachteile, da die d4s 3 amc hat und auch ein stark anderes thermisches Verhalten
 
  • Danke
Reaktionen: urquattroblack

Trabireiter

Flashaholic**
5 April 2012
1.431
682
113
in Sachsen
Moin Jungs.

wie schon geschrieben hab ichs endlich hinbekommen Anduril erfolgreich zu kompilieren und flashen. Für mein erstes Mal war das ein ziemlich langer Weg, am Ende ist es aber recht einfach und an und für sich straight-forward.

Dazu müssen in den Sources für Anduril sowohl die HW-DEF und CFG für die D4 angepasst werden, indem der Teil für die AUX-LEDs hinzugefügt wird. Im Anschluss habe ich die Blinky Modes noch auf Kerze + Gewitter beschränkt, denn Strobo benötige ich nicht.

Das größte Problem war das Kompilieren. Eigentlich ist es sehr einfach, wenn man Atmel Studio nutzt und alle benötigten Datein erstmal im richtigen Ordner sind. Allerdings muss man sich die Infos an allen möglichen Stellen erstmal zusammenlesen, bis dahin gab es sehr viele ??? für mich.

Die dabei entstandene hex Datei wird im Anschluss per AVRdude geflasht und dann hofft man, das alles funktioniert.

Die XM-L, welche ihr in den Bildern angelötet seht, diente mir nur zum Test. Ich wollte kurz prüfen, ob auch alles funktioniert, eh ich die Lampe wieder zusammensetze.

Falls Interesse besteht, würde ich mich mal hinsetzten und das kurz für die Windows User zusammenschreiben.

1.jpg 2.jpg 3.jpg 4.jpg
 

PatX

Flashaholic*
4 September 2010
313
234
43
Augsburg Land
Guten Abend,
bei mir funktioniert es nicht wenn ich es so anlöte wie auf dem dritten Bild. Was mache ich nur falsch... Ich hab keine Spannung auf den Drähten... :S:(
 

Trabireiter

Flashaholic**
5 April 2012
1.431
682
113
in Sachsen
Ja aber, nicht so wie Bild 3 sondern direkt an Akkuspannung. Der Kontakt auf Bild 3 wird vom mcu gesteuert und ist ohne angepasste Firmware stromlos.
 
  • Danke
Reaktionen: PatX

urquattroblack

Flashaholic**
22 Januar 2017
1.640
1.407
113
Also ich habs elegant gelöst.

Ich hab ein Kabel mit Minus fürs Aux board hoch gezogen und Plus einfach auf den Plus des Led Boards gelötet da dieser auf Akku + Liegt.

So brauchst nur 1 Kabel.

Geht sogar noch eleganter:

Plus Aux Board auf Plus Led Board brücken.

Minus Led Board mit ner kleinen Lötfahne auf die Befestigungsschraube des Boards.

Und schon muss man nicht mal die Lampe zerlegen.

Gruß
Manfred
 

urquattroblack

Flashaholic**
22 Januar 2017
1.640
1.407
113
Ups vergessen zu sagen.

Ja meine 2 sind Ti Versionen.

Aber bei der Alu sollte doch auch das Gewinde blank sein.

Gut im Zweifel von der Schraube aufs Batterie Rohr messen ob Durchgang ist.

Wenn nicht muss die Masse vom Treiber mittels eines Kabels hochgeholt werden.
 
  • Danke
Reaktionen: oOFOXOo
Trustfire Taschenlampen

Wubenlight Taschenlampen